DSM-G600, DNS-3xx and NSA-220 Hack Forum

Unfortunately no one can be told what fun_plug is - you have to see it for yourself.

You are not logged in.

#2401 2016-03-27 21:59:26

LuckyBlack
Member
Registered: 2009-04-30
Posts: 51

Re: [REL] Transmission 1.3

It's a pity Kylek , I'm a proud user of ffp-0.5 and it would be awesome to have version 2.92 compiled

Offline

 

#2402 2016-05-02 11:34:17

sonci
Member
Registered: 2009-06-21
Posts: 18

Re: [REL] Transmission 1.3

Can I use transmission 2.92 (0.7 arm) on the DNS 323, or I need a Oabi version?
Will it work?

Offline

 

#2403 2016-05-03 21:25:42

Mijzelf
Member / Developer
Registered: 2008-07-05
Posts: 688

Re: [REL] Transmission 1.3

On a stock DNS323 you can't run 0.7 arm software.

Offline

 

#2404 2016-06-09 07:10:26

fab
Member
Registered: 2010-09-04
Posts: 10

Re: [REL] Transmission 1.3

My transmission 2.83 has stopped working.
I reinstalled the package and I don't get any error when starting it.
Then I can't connect to it and if I try to stop it, I get the following:

Stopping transmission-daemon
killall: transmission-daemon: no process killed

is there a log I can check to see if there are any errors when I start transmission?

Offline

 

#2405 2016-06-10 05:25:59

joligario
Member
Registered: 2011-10-15
Posts: 21

Re: [REL] Transmission 1.3

That message means it wasn't running. What does your start file contain? Have you tried to run the start script manually? The -e argument lets you specify where to save the log file.

Offline

 

#2406 2016-06-11 07:21:13

fab
Member
Registered: 2010-09-04
Posts: 10

Re: [REL] Transmission 1.3

Which one is the start file?

/mnt/HD_a2/ffp/start# ls
LOGIN.sh         lighttpd.sh      portmap.sh       telnetd.sh
SERVERS.sh       mediatomb.sh     rsyncd.sh        transmission.sh
inetd.sh         nfsd.sh          sshd.sh          unfsd.sh
kickwebs.sh      ntpd.sh          syslogd.sh

Offline

 

#2407 2016-06-12 05:32:12

joligario
Member
Registered: 2011-10-15
Posts: 21

Re: [REL] Transmission 1.3

Oh, I guess you don't start with a script. Try this (assuming standard setup) from the command line:

Code:

/ffp/bin/transmission-daemon -g /mnt/HD_a2/.transmission-daemon -e /mnt/HD_a2/.transmission-daemon/transmission.log

Offline

 

#2408 2016-07-10 19:39:21

fab
Member
Registered: 2010-09-04
Posts: 10

Re: [REL] Transmission 1.3

That helped, thanks. Look like it was crashing trying to load some torrents.
I deleted all the torrent files from .transmission-daemon\torrents and that did the trick.

Offline

 

#2409 2016-08-23 16:57:10

GeekGrrl
New member
Registered: 2016-08-23
Posts: 1

Re: [REL] Transmission 1.3

Transmission 2.83 (14282) crashing.
I have transmission setup to only download from 1am-6am. For some reason transmission is crashing. I can't find anything in the logs indicating why it's crashing, it just stops running. it starts fine and I've put a chron job to start the daemon every 1/2 hour since if it's already running it doesn't start a second process.

Offline

 

#2410 2016-08-26 22:44:36

joligario
Member
Registered: 2011-10-15
Posts: 21

Re: [REL] Transmission 1.3

GeekGrrl wrote:

Transmission 2.83 (14282) crashing.
I have transmission setup to only download from 1am-6am. For some reason transmission is crashing. I can't find anything in the logs indicating why it's crashing, it just stops running. it starts fine and I've put a chron job to start the daemon every 1/2 hour since if it's already running it doesn't start a second process.

Possible too many connections. Try limiting to <100

Offline

 

#2411 2017-01-07 13:07:11

sonci
Member
Registered: 2009-06-21
Posts: 18

Re: [REL] Transmission 1.3

Hi
It's been weeks that http://kylek.duckdns.org:31337/files is down,
anywhere else that is possible to download files?

Offline

 

#2412 2017-01-08 11:26:21

serdaruysal
New member
Registered: 2017-01-08
Posts: 1

Re: [REL] Transmission 1.3

Here is my log file, transmission crashing without any reason. I checked everything but nothing helped.



[2017-01-07 23:48:17.677] tr_crypto_utils OpenSSL error: error:24064064:random number generator:SSLEAY_RAND_BYTES:PRNG not seeded (crypto-utils-openssl.c:334)
[2017-01-08 08:01:51.517] tr_crypto_utils OpenSSL error: error:24064064:lib(36):func(100):reason(100) (crypto-utils-openssl.c:334)
[2017-01-08 08:01:51.539] Transmission 2.92 (14714) started (session.c:738)
[2017-01-08 08:01:51.539] RPC Server Adding address to whitelist: 127.0.0.1 (rpc-server.c:903)
[2017-01-08 08:01:51.540] RPC Server Serving RPC and Web requests on port 127.0.0.1:9091/transmission/ (rpc-server.c:1110)
[2017-01-08 08:01:51.540] RPC Server Password required (rpc-server.c:1117)
[2017-01-08 08:01:51.540] UDP Failed to set receive buffer: requested 4194304, got 221184 (tr-udp.c:84)
[2017-01-08 08:01:51.541] UDP Please add the line "net.core.rmem_max = 4194304" to /etc/sysctl.conf (tr-udp.c:89)
[2017-01-08 08:01:51.541] UDP Failed to set send buffer: requested 1048576, got 221184 (tr-udp.c:95)
[2017-01-08 08:01:51.542] UDP Please add the line "net.core.wmem_max = 1048576" to /etc/sysctl.conf (tr-udp.c:100)
[2017-01-08 08:01:51.542] DHT Reusing old id (tr-dht.c:307)
[2017-01-08 08:01:51.542] tr_crypto_utils OpenSSL error: error:24064064:lib(36):func(100):reason(100) (crypto-utils-openssl.c:334)
[2017-01-08 08:01:51.543] DHT Bootstrapping from 146 IPv4 nodes (tr-dht.c:156)
[2017-01-08 08:01:51.543] Using settings from "/mnt/HD/HD_a2/.transmission-daemon" (daemon.c:528)
[2017-01-08 08:01:51.544] Saved "/mnt/HD/HD_a2/.transmission-daemon/settings.json" (variant.c:1266)
[2017-01-08 08:01:51.544] transmission-daemon requiring authentication (daemon.c:554)
[2017-01-08 08:01:51.545] Loaded 1 torrents (session.c:2032)
[2017-01-08 08:01:51.545] Port Forwarding (NAT-PMP) initnatpmp succeeded (0) (natpmp.c:70)
[2017-01-08 08:01:51.546] Port Forwarding (NAT-PMP) sendpublicaddressrequest succeeded (2) (natpmp.c:70)
[2017-01-08 08:01:57.517] Port Forwarding Starting (port-forwarding.c:92)
[2017-01-08 08:01:57.518] tr_crypto_utils OpenSSL error: error:24064064:lib(36):func(100):reason(100) (crypto-utils-openssl.c:334)
[2017-01-08 08:01:58.647] Port Forwarding Starting (port-forwarding.c:92)
[2017-01-08 08:07:51.517] Saved "/mnt/HD/HD_a2/.transmission-daemon/resume/Soyle Ne Zaman -  Laggies 2014 BRRip XviD Turkce Dublaj.avi.02400389b98aa0cd.resume" (variant.c:1266)
[2017-01-08 08:46:23.517] tr_crypto_utils OpenSSL error: error:24064064:random number generator:SSLEAY_RAND_BYTES:PRNG not seeded (crypto-utils-openssl.c:334)
[2017-01-08 09:20:15.517] tr_crypto_utils OpenSSL error: error:24064064:random number generator:SSLEAY_RAND_BYTES:PRNG not seeded (crypto-utils-openssl.c:334)

Offline

 

#2413 2017-01-09 08:51:31

dimanys111
New member
Registered: 2017-01-09
Posts: 1

Re: [REL] Transmission 1.3

Put please Transmission-2.83-1.tgz (ffp-0.5) or earlier.
(link is invalid)

Last edited by dimanys111 (2017-01-09 08:52:46)

Offline

 

#2414 2017-01-12 18:52:33

joligario
Member
Registered: 2011-10-15
Posts: 21

Re: [REL] Transmission 1.3

Seems up to me

Offline

 

#2415 2017-04-27 07:54:03

purpleray
New member
Registered: 2017-04-27
Posts: 3

Re: [REL] Transmission 1.3

bensweet wrote:

Wierd.. I still have ffp.07-oabi and Transmission 2.91 / 2.92 compile but neither launch correctly.  2.84 was fine..  Need to take a closer look at the debugs unless somebody can get it working..

same issue as i compiled Transmission 2.92 for ffp.07-oabi/oarm version then run as daemon, the actual situation is like this

1. Transmission can run by root / nobody in foreground but not working as daemon
2. the error message shown "FAILED. Does user $user have a shell?" as running transmission.sh in both of root and nobody

Any idea or known issue / bugs?

Thanks.

Last edited by purpleray (2017-04-27 08:17:44)

Offline

 

#2416 2017-04-28 10:01:35

Mijzelf
Member / Developer
Registered: 2008-07-05
Posts: 688

Re: [REL] Transmission 1.3

Sounds like a bug in the transmission startscript I wrote in 2012.

Does the scripts start the daemon with

Code:

su <user> -c "command to start transmission"

Su doesn't execute that command. It only starts a shell, and passes the command. By default it uses the shell of <user>, as specified in /etc/passwd. For nobody that is in most case /bin/false, so it can't execute any commands.
You can bypass that by explicitely specify another shell:

Code:

su <user> -s /ffp/bin/sh -c "command to start transmission"

Offline

 

#2417 2017-04-28 17:26:02

purpleray
New member
Registered: 2017-04-27
Posts: 3

Re: [REL] Transmission 1.3

Mijzelf wrote:

Sounds like a bug in the transmission startscript I wrote in 2012.

Does the scripts start the daemon with

Code:

su <user> -c "command to start transmission"

Su doesn't execute that command. It only starts a shell, and passes the command. By default it uses the shell of <user>, as specified in /etc/passwd. For nobody that is in most case /bin/false, so it can't execute any commands.
You can bypass that by explicitely specify another shell:

Code:

su <user> -s /ffp/bin/sh -c "command to start transmission"

seemed to work in running as daemon when I checked daemon status at 3 pids (is it normal one torrent by one pid?).

/ffp/start/transmission.sh status
transmission-daemon is running, pid:
18787 18788 18790

But I accessed neither web interface nor remote GUI by below error messages given the same settings.json I configured for working version 2.83


* web interface
"Connection Failed
Could not connect to the server. You may need to reload the page to reconnect." / "Server not responding"

* Remote GUI
"Connect refused"

any idea to fix? interesting, again everything went well in foreground running   

Thanks

Last edited by purpleray (2017-04-28 18:04:34)

Offline

 

#2418 2017-05-05 07:08:49

purpleray
New member
Registered: 2017-04-27
Posts: 3

Re: [REL] Transmission 1.3

the resolution seems to be the way like putting transmission startscript w/ foreground option (-f) in back ground (&). 

su <user> -s /ffp/bin/sh -c "transmission -f ....." &

Offline

 

Board footer

Powered by PunBB
© Copyright 2002–2010 PunBB