DSM-G600, DNS-3xx and NSA-220 Hack Forum

Unfortunately no one can be told what fun_plug is - you have to see it for yourself.

You are not logged in.

#1 2010-11-12 18:07:00

wiiguy1
Member
Registered: 2010-10-28
Posts: 28

lighthttpd setup

let me first tell you i have a NSA-210

i have bene trying to follow CH3SNAS:Tutorials/lighttpd - NAS-Tweaks

but when i try to followthe first step it already goes wrong

Code:

mkdir /mnt/HD_a2/www
mkdir /mnt/HD_a2/www/pages
mkdir /mnt/HD_a2/www/logs

error

Code:

root@nsa210:/ffp/etc# mkdir /mnt/HD_a2/www
mkdir: cannot create directory `/mnt/HD_a2/www': No such file or directory
root@nsa210:/ffp/etc# mkdir /mnt/HD_a2/www/pages
mkdir: cannot create directory `/mnt/HD_a2/www/pages': No such file or directory
root@nsa210:/ffp/etc# mkdir /mnt/HD_a2/www/logs
mkdir: cannot create directory `/mnt/HD_a2/www/logs': No such file or directory

so i guess im doing something wrong

Offline

 

#2 2010-11-12 19:59:34

Mijzelf
Member / Developer
Registered: 2008-07-05
Posts: 678

Re: lighthttpd setup

A NSA-210 has no HD_a2. You can create a directory www in the root, but if you want to keep your stick compatible with the NSA-320, I suggest you to put it in /ffp:

Code:

mkdir /ffp/www
mkdir /ffp/www/pages
mkdir /ffp/www/logs

If you'd rather put the files on harddisk, use the directory /i-data/md0/www.
In either case you should reflect the directory in lighttpd.conf

Offline

 

#3 2010-11-12 21:08:31

wiiguy1
Member
Registered: 2010-10-28
Posts: 28

Re: lighthttpd setup

ah i understand smile

will try it


edit

now that i want to start the server i get this

root@nsa210:/ffp/start# sh kickwebs.sh start
Kicking webs ...
killall: webs: no process killed
root@nsa210:/ffp/start# sh lighttpd.sh start
Starting /ffp/sbin/lighttpd -f /ffp/etc/lighttpd.conf
2010-11-12 19:53:09: (configfile.c.1210) base-docroot doesn't exist: /i-data/md0/www/pages/
2010-11-12 19:53:09: (server.c.613) setting default values failed
root@nsa210:/ffp/start#


the folder exist

i created a share called www and within there i created a folder called pages



server.document-root        = "/i-data/md0/www/pages/"

server.upload-dirs = ( "/i-data/md0/www/tmp" )

## where to send error-messages to

server.errorlog             = "/i-data/md0/www/logs/error.log"








EDIT 2 :

i fixed it by replacing md0 to 2542aae3


EDIT 3 :

when i start the server
and i try to connect trough my browser to it on port 8080

it says it cant connect


EDIT 4 :

the only time it wont boot is when php is enabled

maybe its because /ffp/bin/php-cgi does not exist

and neither does /tmp/php-cgi.socket

edit 5 : it seems i did not have php installed

im trying to install that now from extra-packages/All

edit 6 : i installed everything from extra-packages/All
but php still wont work


edit 7 :

it all worked out

i needed to reboot smile

Last edited by wiiguy1 (2010-11-12 23:25:18)

Offline

 

Board footer

Powered by PunBB
© Copyright 2002–2010 PunBB