DSM-G600, DNS-3xx and NSA-220 Hack Forum

Unfortunately no one can be told what fun_plug is - you have to see it for yourself.

You are not logged in.

#1 2015-01-26 15:12:50

sudos
Member
Registered: 2015-01-24
Posts: 8

OpenSSL 0.9.8ze & irssi 0.8.17 for Debian 3.1 Sarge chroot install

I've taken the liberty of compiling OpenSSL 0.9.8ze (at this time the current version of 0.9.8) and irssi 0.8.17, the current latest version of irssi to date.

PREREQUISITES:
============

- You must be running a Debian Sarge chroot, NOT ETCH!

- You must have a sarge-backports mirror in your apt sources and have apt-get -t sarge-backports dist-upgrade'd twice in a row to make sure you're completely up to date.
(if you don't know how to set up your apt sources, or want all the good stuff for Sarge, check HERE for code to drop into your sources.list file. Be sure to comment out everything else to prevent repo collisions and conflicts. then apt-get update; apt-get upgrade; apt-get -t sarge-backports dist-upgrade.)

- you must have libglib-2.0-0 and libglib2.0-dev from sarge-backports installed (apt-get -t sarge-backports install ibglib-2.0-0 libglib2.0-dev).
  irssi requires at least glib version 2.6 at compile time... backports had version 2.10.2, so instead of compiling my own, I used the version available, and you should too.

- You should have Screen installed.
  there's no reason to use irssi without screen or tmux, and screen is easily acquirable in Sarge through apt-get.

*** Also make sure you run irssi as a normal user and NOT root! running irssi as root is BAD PRACTICE and is DANGEROUS! ***


PACKAGES:
============


OpenSSL 0.9.8ze, install this first...
irssi 0.8.17, install this second.

With that, you should be up to date on OpenSSL and irssi should be using it.
Feedback would be appreciated heavily into if these actually work for anyone else.

Last edited by sudos (2015-01-26 15:14:33)

Offline

 

Board footer

Powered by PunBB
© Copyright 2002–2010 PunBB