DSM-G600, DNS-3xx and NSA-220 Hack Forum

Unfortunately no one can be told what fun_plug is - you have to see it for yourself.

You are not logged in.

#1 2013-12-10 05:45:30

reddragon1nz
Member
Registered: 2010-04-22
Posts: 6

Can't Ping Hostname from windows

Hi

I'm running my dns-313 with debian successfully now.  Still finding my way around tho.

In windows I can see all my computers under network but I can't see my DNS-313.  I can't even ping DNS-313.  I
I can access via IP and ping Via IP.

These are the detials of my system

Gateway 10.0.0.1
Address of DNS-313 :  10.0.0.3
DNS  10.0.0.1
Subnet 255.255.255.0

I have winbind.  and somba installed  yet still no luck

etc/interaface/interfaces file
--------------------------------------------------------------------------------------
# Used by ifup(8) and ifdown(8). See the interfaces(5) manpage or
# /usr/share/doc/ifupdown/examples for more information.
auto lo
iface lo inet loopback

auto egiga0
#iface egiga0 inet dhcp


iface egiga0 inet static
    address 10.0.0.3
    netmask 255.255.255.0
    network 10.0.0.0
    broadcast 10.0.0.255
    gateway 10.0.0.1


etc/samba/smb.conf file
-----------------------------------------------------------------------------------
[global]
        read raw = yes
        guest account = nobody
        preserve case = yes
        guest ok = yes
        netbios name = DNS-313
        server string = DNS-313
        path = /home
        default = home
        local master = yes
        workgroup = WORKGROUP
        os level = 20
        syslog only = yes
        security = share
        syslog = 1
        guest only = no
        short preserve case = yes
        preferred master = yes
        log level = 3
        wins support = yes
[home]
        force user = root


Any help would be greately appreciated

Offline

 

#2 2013-12-10 23:09:06

aFoP
Member
Registered: 2010-01-27
Posts: 16

Re: Can't Ping Hostname from windows

Hi,

Do you have samba and samba-common also installed?
Please check:
dpkg --get-selections | grep samba
You should see both packages.
Then you will have smbd (samba) and nmbd (winbind) daemons running...
My smb.conf looks like this:

-----------------------------------------------------------------------------------------------------------------------

#======================= Global Settings =======================

[global]
        log file = /var/log/samba/log.%m
        passwd chat = *Enter\snew\s*\spassword:* %n\n *Retype\snew\s*\spassword:* %n\n *password\supdated\ssuccessfully* .
        obey pam restrictions = yes
        interfaces = egiga0
        encrypt passwords = yes
        passwd program = /usr/bin/passwd %u
        passdb backend = tdbsam
        wins support = no
        dns proxy = no
        server string = %h server
        unix password sync = yes
        workgroup = MSHOME
        security = share
        syslog = 0
        panic action = /usr/share/samba/panic-action %d
        max log size = 100
        pam password change = yes
        socket options = TCP_NODELAY IPTOS_LOWDELAY SO_KEEPALIVE SO_RCVBUF=131072 SO_SNDBUF=131072 SO_KEEPALIVE
        load printers = No
        printcap name = /dev/null
        dns proxy = No
        panic action = /usr/share/samba/panic-action %d
        printing = bsd
        print command = lpr -r -P'%p' %s
        lpq command = lpq -P'%p'
        lprm command = lprm -P'%p' %j
[homes]
   comment = Home Directories
   browseable = no

# By default, the home directories are exported read-only. Change the
# next parameter to 'no' if you want to be able to write to them.
   read only = yes

# File creation mask is set to 0700 for security reasons. If you want to
# create files with group=rw permissions, set next parameter to 0775.
   create mask = 0700

# Directory creation mask is set to 0700 for security reasons. If you want to
# create dirs. with group=rw permissions, set next parameter to 0775.
   directory mask = 0700

# By default, \\server\username shares can be connected to by anyone
# with access to the samba server.
# The following parameter makes sure that only "username" can connect
# to \\server\username
# This might need tweaking when using external authentication schemes
   valid users = %S
[printers]
   comment = All Printers
   browseable = no
   path = /var/spool/samba
   printable = yes
   guest ok = no
   read only = yes
   create mask = 0700

# Windows clients look for this share name as a source of downloadable
# printer drivers
[print$]
   comment = Printer Drivers
   path = /var/lib/samba/printers
   browseable = yes
   read only = yes
   guest ok = no
[allusers]
  comment = All Users
  path = /home/share
  valid users = @users
  force group = users
  create mask = 0660
  directory mask = 0771
  writable = yes

[backup]
    wide links = no
    browsable = yes
    writeable = yes
    path = /home/backup
    guest ok = yes
    revalidate = yes
    comment = backup location
    create mode = 775
    directory mode = 775
------------------------------------------------------
And the NAS is seen on the network....

Last edited by aFoP (2013-12-10 23:11:27)

Offline

 

Board footer

Powered by PunBB
© Copyright 2002–2010 PunBB