DSM-G600, DNS-3xx and NSA-220 Hack Forum

Unfortunately no one can be told what fun_plug is - you have to see it for yourself.

You are not logged in.

#1 2011-12-25 01:52:57

raptaop
New member
Registered: 2011-12-21
Posts: 3

inotify support in NSA-221 (Firmware 4.23)

Hi,

I succesfully installed minidlna on my ZyXel NSA-221. The only problem is that it is not detecting new content. It appears that inotify is not working. The call to inotify_init() is returning ENODEV. I tried installing sirmax's inotify package (http://sites.google.com/site/sirmaxwiki/), but still no luck. Does anyone know if there is support for inotify in the kernel? If not, how to get this working.

Thanks for the help,
raptaop

Offline

 

#2 2011-12-26 11:12:54

lachtan86
New member
Registered: 2011-12-26
Posts: 1

Re: inotify support in NSA-221 (Firmware 4.23)

i have same trouble as you. my device is nsa-210 fw 4.23.

# ls -l /dev/inotify
crw-rw-rw-    1 root     root      10,  63 Sep  7 16:19 /dev/inotify

if I run inotify manually, answer is:
Checking /dev/inotify... inotify_init() error: No such device failed

it must be in kernel, fw doesnt support inotify.. i dont know how to solve it :-(

Last edited by lachtan86 (2011-12-26 11:13:57)

Offline

 

#3 2011-12-26 12:28:54

fvdw
Member
Registered: 2009-12-19
Posts: 33

Re: inotify support in NSA-221 (Firmware 4.23)

thats correct, inotify needs to be supported in the kernel.
The version of the kernel used is in principle capable of using it when selected when the kernel was compiled. However with the test you made it seems to benot enabled. The only way to solve it is compile a new(er) kernel. But that's not so easy, also installing it on the zyxels is tricky as they are in flash. (if you do it wrong the box won't boot anymore).
I know this post isn't very helpful

Last edited by fvdw (2011-12-26 12:35:41)

Offline

 

Board footer

Powered by PunBB
© Copyright 2002–2010 PunBB