DSM-G600, DNS-3xx and NSA-220 Hack Forum

Unfortunately no one can be told what fun_plug is - you have to see it for yourself.

You are not logged in.

#1 2010-11-02 16:34:53

Mijzelf
Member / Developer
Registered: 2008-07-05
Posts: 678

FFP on the NSA-nnn

Again ZyXEL managed to make their firmware incompatible with my script  wink , so I had to patch it. (The script, not the firmware).

This version is known to work on the NSA-210, 220, 221 and 320.

More info here

Offline

 

#2 2011-07-15 21:34:37

Mijzelf
Member / Developer
Registered: 2008-07-05
Posts: 678

Re: FFP on the NSA-nnn

Recently I retired my trusty NSA-220 as 'production server'. It's exchanged by a more powerful Kirkwood based NAS. (A Lacie 2Big Network 2, to be exact).

Now the box was available for some testing, and to my surprise the FFPStick didn't run on it! So I solved that problem, and added some new features:
[*]An execute_outside_chroot function to be able to (duh!) execute things outside the chroot.[/*]
[*]exit_ffp. A way to cleanly stop FFP and unmount it's mounts. I had the impression that some of my initial problems were caused by an unclean shutdown, so I added this feature. However, I was not able to confirm that this was really a problem. But I left the function.[/*]
[*]Create a /mnt/HD_a2 symlink, to be more compatible with (tutorials about) the DNS-323.[/*]
[*]Optionally create a /ffp symlink. To be able to use FFP tools in -for instance- PHP scripts running in firmware. This will only work when the firmware has a writable rootfs.[/*]
[*]Optionally don't chroot FFP. This will only work if the /ffp symlink is made, and has some drawbacks. Read the wiki.[/*]

Further improvements:
[*]When using a crappy (slow) USB stick, it turned out that the firmware interfered with the repartitioning. (It took too much time, and the firmware was already mounting the stick.) I changed the script to repartition and create filesystems while the firmware is waiting for usb_key_func.sh to return[/*]
[*]On the same crappy stick it was not always possible to mount a partition directly after creating the filesystem. I added a retry function.[/*]
[*]A clean FFP stick worked only once. On the second boot it refused to start. But when I installed some packages on the first boot, everything went OK.
It turns out the firmware runs "rm ` find /mountpoint/of/stick -type l `" after mounting the stick, removing all symlinks. (This is on firmware 2.10, I don't know if newer versions still have this function.) . So I added a bunch of symlinks in the root of the ext3 partition. (64k filenamelength in total). Now the commandline for rm overflows, and nothing is deleted.[/*]
[*]I splitted usb_key_func.sh in 2 scripts, to make it easier to change things without having to deal with new checksums. Now usb_key_func.sh executes fun_plug.sh, which does all the work[/*]

The new version can be downloaded here, and documentation is here.

Offline

 

Board footer

Powered by PunBB
© Copyright 2002–2010 PunBB