DSM-G600, DNS-3xx and NSA-220 Hack Forum

Unfortunately no one can be told what fun_plug is - you have to see it for yourself.

You are not logged in.

#51 2008-09-02 13:28:56

rb338
Member
Registered: 2008-08-25
Posts: 18

Re: [REL] Transmission 1.3

kihenar wrote:

In my opinion I've tried everything as said in this threat, butt I still get the error "destination folder doesn't exist" and I really don't know what else to do!

I've created a folder mnt/HD_a2/downloads. (I can see this folder directly on my Volume_1)
With the comment # chown -R nobody:501 /mnt/HD_a2/downloads I make it owned by nobody

In the webgui => Preferences => Download to: "/downloads"
I've also set the download folder with the comment # transmission-daemon -w /mnt/HD_a2/downloads

Does anybody have any clue?

Try setting the directory to /mnt/HD_a2/downloads/ in the webui (including the trailing /).
Try chmod 777 /mnt/HD_a2/downloads

Offline

 

#52 2008-09-02 14:36:19

sWirL
New member
Registered: 2008-09-02
Posts: 1

Re: [REL] Transmission 1.3

just realised a problem I have with Transmission..wonder what's wrong.

Everything is fine except when i reboot my dns-323...every torrent on the UI goes missing but the files are still around.

Means if i want to seed them I will need to Add all the torrent files again...am I missing something out?

Offline

 

#53 2008-09-02 17:02:07

Nasp
Member
Registered: 2008-02-18
Posts: 63
Website

Re: [REL] Transmission 1.3

I have make one howto, in Portuguese (My Language) for help Portuguese native language users, for install Transmission on ch3snas/dns-323, the howto :

http://cria-o-teu-avatar.blogspot.com/2 … m-dns.html


one more time, tks Kylek and fonz for your hard work!

Offline

 

#54 2008-09-02 18:15:47

HZ007
New member
Registered: 2008-09-01
Posts: 3

Re: [REL] Transmission 1.3

Got it to work now.

Thanks to everyone!

Offline

 

#55 2008-09-02 20:37:51

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Transmission 1.3

sWirL wrote:

just realised a problem I have with Transmission..wonder what's wrong.

Everything is fine except when i reboot my dns-323...every torrent on the UI goes missing but the files are still around.

Means if i want to seed them I will need to Add all the torrent files again...am I missing something out?

Sounds like Transmission isn't properly stopped, so it doesn't have "time" to save all its config data.

I noticed that Transmission takes quite a while to quit, maybe that's the reason.

Offline

 

#56 2008-09-03 00:17:07

kihenar
New member
Registered: 2008-09-01
Posts: 2

Re: [REL] Transmission 1.3

kihenar wrote:

In my opinion I've tried everything as said in this threat, butt I still get the error "destination folder doesn't exist" and I really don't know what else to do!

I've created a folder mnt/HD_a2/downloads. (I can see this folder directly on my Volume_1)
With the comment # chown -R nobody:501 /mnt/HD_a2/downloads I make it owned by nobody

In the webgui => Preferences => Download to: "/downloads"
I've also set the download folder with the comment # transmission-daemon -w /mnt/HD_a2/downloads

Does anybody have any clue?

KyleK wrote:

I've never dealt much with the "nobody" user, so I can't really provide support for it hmm
You can try and replace "nobody" in the startup script with a username of your choice (even 'root').
Note that you will have to change ownership for the config and download folders as well:

Code:

chown -R <user>:<group> /mnt/HD_a2/.transmission-daemon
chown -R <user>:<group> /mnt/HD_a2/downloads

Stop Transmission before doing this, of course.

Thanx for your answer, but now I've two more questions
- Startup script? Do you mean /ffp/start/transmisson.sh? When I want to edit the file with an editor (in my case "crimson editor") I get the error "Acces Denied"
- Using chown etc..etc.. I get the error "unknow user/group". I don't know how I can create a user/group.

rb338 wrote:

Try setting the directory to /mnt/HD_a2/downloads/ in the webui (including the trailing /).
Try chmod 777 /mnt/HD_a2/downloads

Thanx for your answer, but this doesn't work for me!

Offline

 

#57 2008-09-03 19:17:32

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Transmission 1.3

These "Permission denied" errors are almost always the result of bad updates. If you aren't downloading anything, try simply  removing the .transmission-daemon folder and start transmission again with the startup script (transmission.sh)

I assume you have created user accounts on your NAS, for the Windows Filesharing access? Those users are also available on the console.
You can check that by typing 'cat /etc/passwd'

To edit transmission.sh, make it your user's file with chown (and chmod if necessary), then change the line "user=nobody" and replace nobody with your user name.
If that doesn't work either, try setting it to 'root'.

Offline

 

#58 2008-09-06 03:01:56

zimer
Member
Registered: 2008-09-06
Posts: 16

Re: [REL] Transmission 1.3

Transmission is driving me nuts neutral
Program looks fine, web interface is gorgeous.

It refuses to connect to torrents normally however #@%@#%$%#$. I'm running without blocklists, pex is on, port is forwarded, only one "test" torrent running at a time, even the paused menu is clear. If I grab a linux distro from linux tracker I'll see decent speeds and decent connection numbers. If, however, I grab something popular from places I know should work I can't manage more then 5-10 *connections* for that torrent and dismal speeds. I can't figure what's screwing with my connections.
(mldonkey had similar problems though not quite as severe)

Any trouble shooting tips?

Last edited by zimer (2008-09-06 04:11:19)

Offline

 

#59 2008-09-06 03:09:02

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Transmission 1.3

5-10 torrents on the NAS is way too much. From experience I'd say it can handle about 3 at a time. Remember, the thing has only 64MB of RAM and a rather weak CPU.

Also, Transmission is still missing a key ingredient for good P2P, and that is DHT support. For very popular stuff, DHT is how most peers are found.
If, as you said, a Linux distro loads at good speeds, then there's nothing you can do.

You can maybe try and enable encryption, although you would see slow speeds in other clients as well with that disabled (and it only helps if your ISP blocks bt traffic anyway).

Offline

 

#60 2008-09-06 03:10:23

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Transmission 1.3

Just as a heads up, the downloads won't be available for about a week. Waiting for new internet connection.
I'll let you guys know as soon as everything's back up to normal.

Offline

 

#61 2008-09-06 04:10:46

zimer
Member
Registered: 2008-09-06
Posts: 16

Re: [REL] Transmission 1.3

Sorry, 5-10 connections not torrents. I'm trying to run one torrent at a time to figure this out.

Offline

 

#62 2008-09-08 02:27:00

ttt
New member
Registered: 2008-09-08
Posts: 1

Re: [REL] Transmission 1.3

Someone have files
curl-7.18.1.tgz
Transmission 1.33
please upload them, can't download.
Thank you in advance!!!

Offline

 

#63 2008-09-09 03:08:08

asdf_44y
New member
Registered: 2008-09-09
Posts: 3

Re: [REL] Transmission 1.3

Same here.

I'm also unable to download:

http://kylek.is-a-geek.org:31337/files/curl-7.18.1.tgz
http://kylek.is-a-geek.org:31337/files/ … ffp0.5.tgz
http://kylek.is-a-geek.org:31337/files/ … ffp0.5.tgz

We would very much appreciate it if someone could upload the files here or provide an alternative d/l site. 

thank you for your time!

Last edited by asdf_44y (2008-09-09 03:09:31)

Offline

 

#64 2008-09-09 21:44:02

lekeur
Member
Registered: 2008-09-09
Posts: 13

Re: [REL] Transmission 1.3

Offline

 

#65 2008-09-10 04:20:04

asdf_44y
New member
Registered: 2008-09-09
Posts: 3

Re: [REL] Transmission 1.3

GREAT!!

can i bother you for one more megaupload link?

Automatic-0.2-ffp0.5.tgz
http://kylek.is-a-geek.org:31337/files/ … ffp0.5.tgz

thanks 1000000

Last edited by asdf_44y (2008-09-10 04:25:46)

Offline

 

#66 2008-09-10 20:29:28

lekeur
Member
Registered: 2008-09-09
Posts: 13

Re: [REL] Transmission 1.3

Sorry I have not dl this one.

Offline

 

#67 2008-09-10 21:20:10

stevo
New member
Registered: 2008-09-10
Posts: 2
Website

Re: [REL] Transmission 1.3

hmm, that megaupload worked (thanks), but was quite painful. Here's an alternative

http://stevo.isa-geek.net:8080/Transmis … ffp0.5.tgz

Offline

 

#68 2008-09-16 22:04:22

Fevida
Member
From: Eindhoven, Netherlands
Registered: 2008-08-03
Posts: 12

Re: [REL] Transmission 1.3

Here is automatic 0.2.


Attachments:
Attachment Icon Automatic-0.2-ffp0.5.tgz, Size: 16,452 bytes, Downloads: 577

Offline

 

#69 2008-09-17 14:59:30

Pejn
Member
Registered: 2007-12-17
Posts: 61

Re: [REL] Transmission 1.3

looks like 1.34 is out, nothing special some bugfix

Offline

 

#70 2008-09-23 21:57:53

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Transmission 1.3

Hey everyone,
after 2 internet-less weeks (switched ISP), I'm finally back. Download links should work again, and I'm currently checking out the new Transmission release and making a build. As soon as everything's ready you can read about it here.

Offline

 

#71 2008-09-23 23:25:25

lekeur
Member
Registered: 2008-09-09
Posts: 13

Re: [REL] Transmission 1.3

Thank you for your great work Kykek.  !

Offline

 

#72 2008-09-24 22:46:33

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Transmission 1.3

I have packaged the new version 1.34, which brings only minor fixes.
Get it from the first post of the thread and have fun!

Offline

 

#73 2008-09-26 05:34:09

sandwich
Member
Registered: 2008-09-26
Posts: 5

Re: [REL] Transmission 1.3

Hi guys.  New to this forum and the DNS-323 and hoping someone can help me out.  I have downloaded the required files to Volume_1.  When I try to install I get the following error.

root@NAS:/mnt/HD_a2# funpkg -i curl-7181.tgz
tar: invalid gzip magic
FATAL: curl-7181.tgz: Failed to unpack package
root@NAS:/mnt/HD_a2#

I am SSHing into the DNS using Terminal in OSX 10.5

Offline

 

#74 2008-09-26 18:45:04

KyleK
Member
From: Dresden, Germany
Registered: 2007-12-05
Posts: 1178

Re: [REL] Transmission 1.3

It seems something went wrong when you downloaded the file. I just tested it myself and it works fine.
Just download the file again.

Offline

 

#75 2008-09-26 19:21:17

sandwich
Member
Registered: 2008-09-26
Posts: 5

Re: [REL] Transmission 1.3

Ok thanks, I'll give it shot.  Should I be downloading the files directly to my DNS 323?

I also had this error occur no matter what file I was trying to install...

Offline

 

Board footer

Powered by PunBB
© Copyright 2002–2010 PunBB